blob: 8b0c78667465758c7b5da045267fea041d29e7f6 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Improved drop-in replacement for std::function"
2DESCRIPTION = "Provides improved implementations of std::function."
3HOMEPAGE = "https://naios.github.io/function2"
4LICENSE = "BSL-1.0"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
Andrew Geissler69721092021-07-23 12:57:00 -04006SRCREV = "02ca99831de59c7c3a4b834789260253cace0ced"
Brad Bishop19323692019-04-05 15:28:33 -04007PV .= "+git${SRCPV}"
8
9SRC_URI += "gitsm://github.com/Naios/function2"
10
11S = "${WORKDIR}/git"
12
13inherit cmake
14inherit ptest
15
16# Installs some data to incorrect top-level /usr directory
Patrick Williams213cb262021-08-07 19:21:33 -050017do_install:append() {
Brad Bishop19323692019-04-05 15:28:33 -040018 mkdir -p ${D}/${datadir}/function2
19 mv ${D}/${prefix}/Readme.md ${D}/${datadir}/function2/
20 mv ${D}/${prefix}/LICENSE.txt ${D}/${datadir}/function2/
21}