blob: ba21ffaf0235cf0751b795b3c49097fb1ee3d1a1 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "The goal of this project is to provide a tiny library that would \
2facilitate the common operations with sizes in bytes."
3HOMEPAGE = "https://github.com/rhinstaller/libbytesize"
4LICENSE = "LGPLv2+"
5SECTION = "devel/lib"
6
7LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
8
9S = "${WORKDIR}/git"
10B = "${S}"
11
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050012SRCREV = "732ee8d28492e4bc9b52c29bcb81a5c19388d002"
Andrew Geissler82c905d2020-04-13 13:39:40 -050013SRC_URI = "git://github.com/rhinstaller/libbytesize;branch=master"
14
15inherit gettext autotools python3native
16
17DEPENDS += " \
18 libpcre2 \
19 gmp \
20 mpfr \
21 gettext-native \
22"
23
Patrick Williams213cb262021-08-07 19:21:33 -050024FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}/bytesize"
Andrew Geissler82c905d2020-04-13 13:39:40 -050025
26PACKAGECONFIG ??= "python3"
27PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3-core"
28
29EXTRA_OECONF = "--without-gtk-doc"
30EXTRA_OEMAKE = "py3libdir=${PYTHON_SITEPACKAGES_DIR}"