blob: 0fa229662f828194781a34201f39a5579da03dd5 [file] [log] [blame]
Andrew Geisslere34f8962021-04-15 15:53:51 -05001SUMMARY = "the Apache Kafka C/C++ client library"
2DESCRIPTION = "librdkafka is a C library implementation of the Apache Kafka protocol, providing Producer, Consumer and Admin clients."
3HOMEPAGE = "https://github.com/edenhill/librdkafka"
4SECTION = "libs"
5LICENSE = "BSD-2-Clause"
6
7LIC_FILES_CHKSUM = " \
8file://LICENSE;md5=2be8675acbfdac48935e73897af5f646 \
9"
10
11SRC_URI = "git://github.com/edenhill/librdkafka;protocol=https \
12 file://0001_fix_absolute_path_usage.patch"
13SRCREV = "1a722553638bba85dbda5050455f7b9a5ef302de"
14
15DEPENDS = "zlib openssl zstd"
16
17inherit cmake
18
19S = "${WORKDIR}/git"
20
Patrick Williams213cb262021-08-07 19:21:33 -050021FILES:${PN} += "${datadir}"
Andrew Geisslere34f8962021-04-15 15:53:51 -050022
23EXTRA_OECMAKE += "-DRDKAFKA_BUILD_EXAMPLES=OFF -DRDKAFKA_BUILD_TESTS=OFF"