blob: 3549cb2153c2f956cdafb4017baf90314b1b4c9b [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "A utility for finding interesting messages in log files"
2DESCRIPTION = "Logwarn searches for interesting messages in log files, \
3 where 'interesting' is defined by a user-supplied list of positive and \
4 negative extended regular expressions. \
5"
6HOMEPAGE = "https://github.com/archiecobbs/logwarn/wiki"
7SECTION = "console/utils"
8
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
12SRC_URI = "https://s3.amazonaws.com/archie-public/${BPN}/${BP}.tar.gz"
13
14SRC_URI[md5sum] = "e544a6230673ea54f7430bf817bb39d8"
15SRC_URI[sha256sum] = "8dbfcf9b28c782ab3bddd6a620d4fb95d1b0ffcbe93276996cdc4800aa9aebd1"
16
17inherit autotools-brokensep
18
19# This directory is NOT volatile.
20#
21lcl_default_state_dir = "${localstatedir}/lib/logwarn"
22
23CFLAGS += '-DDEFAULT_STATE_DIR=\""${lcl_default_state_dir}\""'
24
25CACHED_CONFIGUREVARS += " \
26 ac_cv_path_BASH_SHELL=${base_bindir}/bash \
27 ac_cv_path_CAT=${base_bindir}/cat \
28 ac_cv_path_RM=${base_bindir}/rm \
29 ac_cv_path_SED=${base_bindir}/sed \
30"
31
32# Make sure some files exist for autoreconf.
33#
Patrick Williams213cb262021-08-07 19:21:33 -050034do_configure:prepend () {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050035 touch ${S}/NEWS
36 touch ${S}/ChangeLog
37 touch ${S}/README
38}
39
40# Create a directory for logfile state info, usually under /var/lib.
41#
Patrick Williams213cb262021-08-07 19:21:33 -050042do_install:append () {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050043 install -d ${D}${lcl_default_state_dir}
44}
45
46# Make a package for the nagios plug-in (script).
47#
48PACKAGES += "${PN}-nagios"
49
Patrick Williams213cb262021-08-07 19:21:33 -050050FILES:${PN}-nagios = "${nonarch_libdir}/nagios"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050051
Patrick Williams213cb262021-08-07 19:21:33 -050052RDEPENDS:${PN}-nagios += "bash coreutils sed"