blob: b77709485f676dbcd3e126ceaa976e1aed328ea1 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "mcelog daemon accounts memory and some other errors in various ways."
2DESCRIPTION = "mcelog is required by both 32bit x86 Linux kernels (since 2.6.30) \
3and 64bit Linux kernels (since early 2.6 kernel releases) to log machine checks \
4and should run on all Linux systems that need error handling."
5HOMEPAGE = "http://mcelog.org/"
6SECTION = "System Environment/Base"
7
8SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http; \
Andrew Geisslereef63862021-01-29 15:58:13 -06009 file://0001-test-avoid-the-pfa-test-hang.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050010 file://run-ptest \
11"
12
Andrew Geissler97771a32021-03-05 15:23:11 -060013SRCREV = "7b776a8c005b60572f49797e81287540f99fff1f"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
15LICENSE = "GPLv2"
16LIC_FILES_CHKSUM = "file://README.md;md5=74bb47b9a68850cb398665cf78b31de6"
17
18S = "${WORKDIR}/git"
19
20inherit autotools-brokensep ptest
21
22COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
23
Patrick Williams213cb262021-08-07 19:21:33 -050024do_install:append() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050025 install -d ${D}${sysconfdir}/cron.hourly
26 install -m 0755 ${S}/mcelog.cron ${D}${sysconfdir}/cron.hourly/
27 sed -i 's/bash/sh/' ${D}${sysconfdir}/cron.hourly/mcelog.cron
28}
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}
32 cp -r ${S}/tests ${S}/input ${D}${PTEST_PATH}
33 sed -i 's#../../mcelog#mcelog#' ${D}${PTEST_PATH}/tests/test
34}
35
Patrick Williams213cb262021-08-07 19:21:33 -050036RDEPENDS:${PN}-ptest += "make bash mce-inject"