blob: 797e91eae1913ec2590c1405fff305de3a9d1568 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "A portable version of the mg maintained by the OpenBSD team"
2HOMEPAGE = "http://homepage.boetes.org/software/mg/"
3LICENSE = "PD"
4LIC_FILES_CHKSUM = "file://version.c;md5=1895eb37bf6bd79cdc5c89d8166fabfb"
5DEPENDS = "ncurses libbsd"
6SECTION = "console/editors"
7
Andrew Geissler69721092021-07-23 12:57:00 -04008SRCREV = "688f49cd67ab30dfa6482c74815e117cbf7af63a"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05009SRC_URI = "git://github.com/hboetes/mg \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010 file://0001-fileio-Include-sys-param.h-for-MAXNAMLEN.patch \
11 file://0002-fileio-Define-DEFFILEMODE-if-platform-is-missing.patch \
12 "
Patrick Williams213cb262021-08-07 19:21:33 -050013SRC_URI:append:libc-musl = "\
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014 file://0001-Undefine-REGEX-for-musl-based-systems.patch \
15 "
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050016
17S = "${WORKDIR}/git"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018
19# CFLAGS isn't in EXTRA_OEMAKE, as the makefile picks it up via ?=
20EXTRA_OEMAKE = "\
21 'CC=${CC}' \
22 'LDFLAGS=${LDFLAGS}' \
23 \
24 'prefix=${prefix}' \
25 'bindir=${bindir}' \
26 'libdir=${libdir}' \
27 'includedir=${includedir}' \
28 'mandir=${mandir}' \
29 'PKG_CONFIG=pkg-config' \
30"
31
32CFLAGS += "-I${STAGING_INCDIR}/bsd"
33
34do_install () {
35 oe_runmake install DESTDIR=${D}
36}
37
38inherit pkgconfig