blob: f9dc58a4c00ad60f327fb98a774beb097b19f7e9 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "OpenLDAP Directory Service"
2DESCRIPTION = "OpenLDAP Software is an open source implementation of the Lightweight Directory Access Protocol."
3HOMEPAGE = "http://www.OpenLDAP.org/license.html"
4# The OpenLDAP Public License - see the HOMEPAGE - defines
5# the license. www.openldap.org claims this is Open Source
6# (see http://www.openldap.org), the license appears to be
7# basically BSD. opensource.org does not record this license
8# at present (so it is apparently not OSI certified).
9LICENSE = "OpenLDAP"
Andrew Geisslereef63862021-01-29 15:58:13 -060010LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=b6dea6c170362fc46381fe3690c722cb \
Andrew Geissler82c905d2020-04-13 13:39:40 -050011 file://LICENSE;md5=153d07ef052c4a37a8fac23bc6031972 \
12 "
13SECTION = "libs"
14
15LDAP_VER = "${@'.'.join(d.getVar('PV').split('.')[0:2])}"
16
17SRC_URI = "http://www.openldap.org/software/download/OpenLDAP/openldap-release/${BP}.tgz \
18 file://openldap-m4-pthread.patch \
19 file://openldap-2.4.28-gnutls-gcrypt.patch \
20 file://use-urandom.patch \
21 file://initscript \
22 file://slapd.service \
23 file://thread_stub.patch \
24 file://openldap-CVE-2015-3276.patch \
25 file://remove-user-host-pwd-from-version.patch \
26"
27
Andrew Geissler32b11992021-03-31 13:37:05 -050028SRC_URI[md5sum] = "c203d735ba69976e5b28dc39006f29b5"
29SRC_URI[sha256sum] = "57b59254be15d0bf6a9ab3d514c1c05777b02123291533134a87c94468f8f47b"
Andrew Geissler82c905d2020-04-13 13:39:40 -050030
31DEPENDS = "util-linux groff-native"
32
33# The original top.mk used INSTALL, not INSTALL_STRIP_PROGRAM when
34# installing .so and executables, this fails in cross compilation
35# environments
36SRC_URI += "file://install-strip.patch"
37
38inherit autotools-brokensep update-rc.d systemd
39
40# CV SETTINGS
41# Required to work round AC_FUNC_MEMCMP which gets the wrong answer
42# when cross compiling (should be in site?)
43EXTRA_OECONF += "ac_cv_func_memcmp_working=yes"
44
45# CONFIG DEFINITIONS
46# The following is necessary because it cannot be determined for a
47# cross compile automagically. Select should yield fine on all OE
48# systems...
49EXTRA_OECONF += "--with-yielding-select=yes"
50# Shared libraries are nice...
51EXTRA_OECONF += "--enable-dynamic"
52
53PACKAGECONFIG ??= "gnutls modules \
54 mdb ldap meta monitor null passwd shell proxycache dnssrv \
55 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
56"
57#--with-tls with TLS/SSL support auto|openssl|gnutls [auto]
58PACKAGECONFIG[gnutls] = "--with-tls=gnutls,,gnutls libgcrypt"
59PACKAGECONFIG[openssl] = "--with-tls=openssl,,openssl"
60
61PACKAGECONFIG[sasl] = "--with-cyrus-sasl,--without-cyrus-sasl,cyrus-sasl"
62PACKAGECONFIG[modules] = "lt_cv_dlopen_self=yes --enable-modules,--disable-modules,libtool"
63PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6"
64
65# SLAPD options
66#
67# UNIX crypt(3) passwd support:
68EXTRA_OECONF += "--enable-crypt"
69
70# SLAPD BACKEND
71#
72# The backend must be set by the configuration. This controls the
73# required database.
74#
75# Backends="bdb dnssrv hdb ldap mdb meta monitor ndb null passwd perl relay shell sock sql"
76#
77# Note that multiple backends can be built. The ldbm backend requires a
78# build-time choice of database API. The bdb backend forces this to be
79# DB4. To use the gdbm (or other) API the Berkely database module must
80# be removed from the build.
81md = "${libexecdir}/openldap"
82#
83#--enable-bdb enable Berkeley DB backend no|yes|mod yes
84# The Berkely DB is the standard choice. This version of OpenLDAP requires
85# the version 4 implementation or better.
86PACKAGECONFIG[bdb] = "--enable-bdb=yes,--enable-bdb=no,db"
87
88#--enable-dnssrv enable dnssrv backend no|yes|mod no
89PACKAGECONFIG[dnssrv] = "--enable-dnssrv=mod,--enable-dnssrv=no"
90
91#--enable-hdb enable Hierarchical DB backend no|yes|mod no
92PACKAGECONFIG[hdb] = "--enable-hdb=yes,--enable-hdb=no,db"
93
94#--enable-ldap enable ldap backend no|yes|mod no
95PACKAGECONFIG[ldap] = "--enable-ldap=mod,--enable-ldap=no,"
96
97#--enable-mdb enable mdb database backend no|yes|mod [yes]
98PACKAGECONFIG[mdb] = "--enable-mdb=yes,--enable-mdb=no,"
99
100#--enable-meta enable metadirectory backend no|yes|mod no
101PACKAGECONFIG[meta] = "--enable-meta=mod,--enable-meta=no,"
102
103#--enable-monitor enable monitor backend no|yes|mod yes
104PACKAGECONFIG[monitor] = "--enable-monitor=mod,--enable-monitor=no,"
105
106#--enable-ndb enable MySQL NDB Cluster backend no|yes|mod [no]
107PACKAGECONFIG[ndb] = "--enable-ndb=mod,--enable-ndb=no,"
108
109#--enable-null enable null backend no|yes|mod no
110PACKAGECONFIG[null] = "--enable-null=mod,--enable-null=no,"
111
112#--enable-passwd enable passwd backend no|yes|mod no
113PACKAGECONFIG[passwd] = "--enable-passwd=mod,--enable-passwd=no,"
114
115#--enable-perl enable perl backend no|yes|mod no
116# This requires a loadable perl dynamic library, if enabled without
117# doing something appropriate (building perl?) the build will pick
118# up the build machine perl - not good (inherit perlnative?)
119PACKAGECONFIG[perl] = "--enable-perl=mod,--enable-perl=no,perl"
120
121#--enable-relay enable relay backend no|yes|mod [yes]
122PACKAGECONFIG[relay] = "--enable-relay=mod,--enable-relay=no,"
123
124#--enable-shell enable shell backend no|yes|mod no
125# configure: WARNING: Use of --without-threads is recommended with back-shell
126PACKAGECONFIG[shell] = "--enable-shell=mod --without-threads,--enable-shell=no,"
127
128#--enable-sock enable sock backend no|yes|mod [no]
129PACKAGECONFIG[sock] = "--enable-sock=mod,--enable-sock=no,"
130
131#--enable-sql enable sql backend no|yes|mod no
132# sql requires some sql backend which provides sql.h, sqlite* provides
133# sqlite.h (which may be compatible but hasn't been tried.)
134PACKAGECONFIG[sql] = "--enable-sql=mod,--enable-sql=no,sqlite3"
135
136#--enable-dyngroup Dynamic Group overlay no|yes|mod no
137# This is a demo, Proxy Cache defines init_module which conflicts with the
138# same symbol in dyngroup
139PACKAGECONFIG[dyngroup] = "--enable-dyngroup=mod,--enable-dyngroup=no,"
140
141#--enable-proxycache Proxy Cache overlay no|yes|mod no
142PACKAGECONFIG[proxycache] = "--enable-proxycache=mod,--enable-proxycache=no,"
Patrick Williams213cb262021-08-07 19:21:33 -0500143FILES:${PN}-overlay-proxycache = "${md}/pcache-*.so.*"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500144PACKAGES += "${PN}-overlay-proxycache"
145
146# Append URANDOM_DEVICE='/dev/urandom' to CPPFLAGS:
147# This allows tls to obtain random bits from /dev/urandom, by default
148# it was disabled for cross-compiling.
Patrick Williams213cb262021-08-07 19:21:33 -0500149CPPFLAGS:append = " -D_GNU_SOURCE -DURANDOM_DEVICE=\'/dev/urandom\' -fPIC"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500150
Patrick Williams213cb262021-08-07 19:21:33 -0500151LDFLAGS:append = " -pthread"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500152
153do_configure() {
Andrew Geissler82c905d2020-04-13 13:39:40 -0500154 rm -f ${S}/libtool
155 aclocal
156 libtoolize --force --copy
157 gnu-configize
Andrew Geisslerac970dd2021-02-12 15:32:45 -0600158 cp ${STAGING_DATADIR_NATIVE}/libtool/build-aux/ltmain.sh ${S}/build
159 cp ${STAGING_DATADIR_NATIVE}/libtool/build-aux/missing ${S}/build
160 cp ${STAGING_DATADIR_NATIVE}/libtool/build-aux/compile ${S}/build
Andrew Geissler82c905d2020-04-13 13:39:40 -0500161 autoconf
162 oe_runconf
163}
164
165LEAD_SONAME = "libldap-${LDAP_VER}.so.*"
166
167# The executables go in a separate package. This allows the
168# installation of the libraries with no daemon support.
169# Each module also has its own package - see above.
170PACKAGES += "${PN}-slapd ${PN}-slurpd ${PN}-bin"
171
172# Package contents - shift most standard contents to -bin
Patrick Williams213cb262021-08-07 19:21:33 -0500173FILES:${PN} = "${libdir}/lib*.so.* ${sysconfdir}/openldap/ldap.* ${localstatedir}/${BPN}/data"
174FILES:${PN}-slapd = "${sysconfdir}/init.d ${libexecdir}/slapd ${sbindir} ${localstatedir}/run ${localstatedir}/volatile/run \
Andrew Geissler82c905d2020-04-13 13:39:40 -0500175 ${sysconfdir}/openldap/slapd.* ${sysconfdir}/openldap/schema \
176 ${sysconfdir}/openldap/DB_CONFIG.example ${systemd_unitdir}/system/*"
Patrick Williams213cb262021-08-07 19:21:33 -0500177FILES:${PN}-slurpd = "${libexecdir}/slurpd ${localstatedir}/openldap-slurp"
178FILES:${PN}-bin = "${bindir}"
179FILES:${PN}-dev = "${includedir} ${libdir}/lib*.so ${libdir}/*.la ${libexecdir}/openldap/*.a ${libexecdir}/openldap/*.la ${libexecdir}/openldap/*.so"
180FILES:${PN}-dbg += "${libexecdir}/openldap/.debug"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500181
Patrick Williams213cb262021-08-07 19:21:33 -0500182do_install:append() {
Andrew Geissler82c905d2020-04-13 13:39:40 -0500183 install -d ${D}${sysconfdir}/init.d
184 cat ${WORKDIR}/initscript > ${D}${sysconfdir}/init.d/openldap
185 chmod 755 ${D}${sysconfdir}/init.d/openldap
186 # This is duplicated in /etc/openldap and is for slapd
187 rm -f ${D}${localstatedir}/openldap-data/DB_CONFIG.example
188
189 # Installing slapd under ${sbin} is more FHS and LSB compliance
190 mv ${D}${libexecdir}/slapd ${D}/${sbindir}/slapd
191 rmdir --ignore-fail-on-non-empty ${D}${libexecdir}
192 SLAPTOOLS="slapadd slapcat slapdn slapindex slappasswd slaptest slapauth slapacl slapschema"
193 cd ${D}/${sbindir}/
194 rm -f ${SLAPTOOLS}
195 for i in ${SLAPTOOLS}; do ln -sf slapd $i; done
196
197 rmdir "${D}${localstatedir}/run"
198 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
199
200 install -d ${D}${systemd_unitdir}/system/
201 install -m 0644 ${WORKDIR}/slapd.service ${D}${systemd_unitdir}/system/
202 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/*.service
203
204 # Uses mdm as the database
205 # and localstatedir as data directory ...
206 sed -e 's/# modulepath/modulepath/' \
207 -e 's/# moduleload\s*back_bdb.*/moduleload back_mdb/' \
208 -e 's/database\s*bdb/database mdb/' \
209 -e 's%^directory\s*.*%directory ${localstatedir}/${BPN}/data/%' \
210 -i ${D}${sysconfdir}/openldap/slapd.conf
211
212 mkdir -p ${D}${localstatedir}/${BPN}/data
213
214
215}
216
217INITSCRIPT_PACKAGES = "${PN}-slapd"
Patrick Williams213cb262021-08-07 19:21:33 -0500218INITSCRIPT_NAME:${PN}-slapd = "openldap"
219INITSCRIPT_PARAMS:${PN}-slapd = "defaults"
220SYSTEMD_SERVICE:${PN}-slapd = "hostapd.service"
221SYSTEMD_AUTO_ENABLE:${PN}-slapd ?= "disable"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500222
223
224PACKAGES_DYNAMIC += "^${PN}-backends.* ^${PN}-backend-.*"
225
226# The modules require their .so to be dynamicaly loaded
Patrick Williams213cb262021-08-07 19:21:33 -0500227INSANE_SKIP:${PN}-backend-dnssrv += "dev-so"
228INSANE_SKIP:${PN}-backend-ldap += "dev-so"
229INSANE_SKIP:${PN}-backend-meta += "dev-so"
230INSANE_SKIP:${PN}-backend-mdb += "dev-so"
231INSANE_SKIP:${PN}-backend-monitor += "dev-so"
232INSANE_SKIP:${PN}-backend-null += "dev-so"
233INSANE_SKIP:${PN}-backend-passwd += "dev-so"
234INSANE_SKIP:${PN}-backend-shell += "dev-so"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500235
236
Patrick Williams213cb262021-08-07 19:21:33 -0500237python populate_packages:prepend () {
Andrew Geissler82c905d2020-04-13 13:39:40 -0500238 backend_dir = d.expand('${libexecdir}/openldap')
239 do_split_packages(d, backend_dir, 'back_([a-z]*)\.so$', 'openldap-backend-%s', 'OpenLDAP %s backend', prepend=True, extra_depends='', allow_links=True)
240 do_split_packages(d, backend_dir, 'back_([a-z]*)\-.*\.so\..*$', 'openldap-backend-%s', 'OpenLDAP %s backend', extra_depends='', allow_links=True)
241
242 metapkg = "${PN}-backends"
Patrick Williams213cb262021-08-07 19:21:33 -0500243 d.setVar('ALLOW_EMPTY:' + metapkg, "1")
244 d.setVar('FILES:' + metapkg, "")
Andrew Geissler82c905d2020-04-13 13:39:40 -0500245 metapkg_rdepends = []
246 packages = d.getVar('PACKAGES').split()
247 for pkg in packages[1:]:
248 if pkg.count("openldap-backend-") and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale"):
249 metapkg_rdepends.append(pkg)
Patrick Williams213cb262021-08-07 19:21:33 -0500250 d.setVar('RDEPENDS:' + metapkg, ' '.join(metapkg_rdepends))
251 d.setVar('DESCRIPTION:' + metapkg, 'OpenLDAP backends meta package')
Andrew Geissler82c905d2020-04-13 13:39:40 -0500252 packages.append(metapkg)
253 d.setVar('PACKAGES', ' '.join(packages))
254}
255
256BBCLASSEXTEND = "native"