blob: 423780154713ba268397e957b248d0ca923402ed [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "C++/Boost Asio based websocket client/server library."
2SECTION = "libs/network"
3HOMEPAGE = "https://github.com/zaphoyd/websocketpp"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=4d168d763c111f4ffc62249870e4e0ea"
6
7DEPENDS = " ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'openssl boost zlib', '', d)} "
8
9SRC_URI = "git://github.com/zaphoyd/websocketpp.git;protocol=https \
10 file://0001-cmake-Use-GNUInstallDirs.patch \
11 file://855.patch \
12 file://857.patch \
13 file://0001-Correct-clang-compiler-flags.patch \
14 "
15
16EXTRA_OECMAKE = "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', '-DBUILD_EXAMPLES=ON -DBUILD_TESTS=ON', '', d)} "
17
18# this is an header only library, do not depend on the main package
Patrick Williams213cb262021-08-07 19:21:33 -050019RDEPENDS:${PN}-dev = ""
Andrew Geissler82c905d2020-04-13 13:39:40 -050020
21# to add this package to an SDK, since it isn't a reverse-dependency of anything, just use something like this:
Patrick Williams213cb262021-08-07 19:21:33 -050022# TOOLCHAIN_TARGET_TASK:append = " websocketpp-dev"
Andrew Geissler82c905d2020-04-13 13:39:40 -050023
24# tag 0.8.2
25SRCREV= "56123c87598f8b1dd471be83ca841ceae07f95ba"
26
27S = "${WORKDIR}/git"
28
29inherit cmake
30
31PACKAGES =+ "${PN}-examples"
32
Patrick Williams213cb262021-08-07 19:21:33 -050033FILES:${PN}-examples = "${docdir}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050034
Patrick Williams213cb262021-08-07 19:21:33 -050035do_install:append() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050036 install -d ${D}${docdir}/${BPN}
37 cp -R ${S}/examples ${D}${docdir}/${BPN}
38}