blob: adfc03a16ea2926537fa1bf9a5b58aa0f210972d [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001DESCRIPTION = "A modern, C++-native, header-only, test framework for unit-tests, \
2TDD and BDD - using C++11, C++14, C++17 and later."
3AUTHOR = "Phil Nash, Martin Horenovsky and others"
4HOMEPAGE = "https://github.com/catchorg/Catch2"
5LICENSE = "BSL-1.0"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
7
Andrew Geissler97771a32021-03-05 15:23:11 -06008SRC_URI = "git://github.com/catchorg/Catch2.git;branch=v2.x"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -07009SRCREV = "5c88067bd339465513af4aec606bd2292f1b594a"
Brad Bishopc342db32019-05-15 21:57:59 -040010
11S = "${WORKDIR}/git"
12
13inherit cmake python3native
14
Patrick Williams213cb262021-08-07 19:21:33 -050015do_install:append() {
Brad Bishopc342db32019-05-15 21:57:59 -040016 rm ${D}${datadir}/Catch2/lldbinit
17 rm ${D}${datadir}/Catch2/gdbinit
18 rmdir ${D}${datadir}/Catch2/
19}
20# Header-only library
Patrick Williams213cb262021-08-07 19:21:33 -050021RDEPENDS:${PN}-dev = ""
22RRECOMMENDS:${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"