blob: 7554014fab783c8ff9754f2a90f23cbba4976234 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "a utility to add users/groups to the system"
2DESCRIPTION = "adduser, addgroup - add a user or group to the system"
3HOMEPAGE = "https://salsa.debian.org/debian/adduser"
4SECTION = "base/utils"
5
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://debian/copyright;md5=caed49ab166f22ef31bf1127f558d0ef"
8
9SRC_URI = "https://launchpad.net/debian/+archive/primary/+sourcefiles/adduser/${PV}/${BPN}_${PV}.tar.xz \
10 file://adduser-add-M-option-for-useradd.patch \
Brad Bishope42b3e32020-01-15 22:08:42 -050011 file://0001-adduser-set-default-shell-with-sbin-nologin.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012"
13
14SRC_URI[md5sum] = "44ba2475ebdaafc9613236bdda321c97"
15SRC_URI[sha256sum] = "3e9eea661c9aac6b2c791bfcc1de3a9c6a422d45c8f3d38ed417737ed3166ffc"
16
17S = "${WORKDIR}/${BPN}"
18
19inherit cpan-base update-alternatives
20
21do_install() {
22 install -d ${D}${sbindir}
23 install -m 0755 ${S}/adduser ${D}${sbindir}
24 install -m 0755 ${S}/deluser ${D}${sbindir}
25
Brad Bishop19323692019-04-05 15:28:33 -040026 install -D -m 0644 ${S}/AdduserCommon.pm ${D}${libdir}/perl5/${@get_perl_version(d)}/Debian/AdduserCommon.pm
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027 sed -i -e "s/VERSION/${PV}/" ${D}${sbindir}/*
28
29 install -d ${D}/${sysconfdir}
30 install -m 0644 ${S}/*.conf ${D}/${sysconfdir}
31
32 install -d ${D}${mandir}/man5
33 install -m 0644 ${S}/doc/*.conf.5 ${D}${mandir}/man5
34 install -d ${D}${mandir}/man8
35 install -m 0644 ${S}/doc/*.8 ${D}${mandir}/man8
36 install -d ${D}${docdir}/${BPN}
37 cp -rf ${S}/examples ${D}${docdir}/${BPN}
38}
39
Patrick Williams213cb262021-08-07 19:21:33 -050040RDEPENDS:${PN} += "\
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080041 shadow \
42 perl-module-getopt-long \
43 perl-module-overloading \
44 perl-module-file-find \
45 perl-module-file-temp \
46"
47
Patrick Williams213cb262021-08-07 19:21:33 -050048ALTERNATIVE:${PN} = "adduser deluser addgroup delgroup"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080049ALTERNATIVE_PRIORITY = "60"
50ALTERNATIVE_LINK_NAME[adduser] = "${sbindir}/adduser"
51ALTERNATIVE_LINK_NAME[deluser] = "${sbindir}/deluser"
52ALTERNATIVE_LINK_NAME[addgroup] = "${sbindir}/addgroup"
53ALTERNATIVE_LINK_NAME[delgroup] = "${sbindir}/delgroup"
54ALTERNATIVE_TARGET[addgroup] = "${sbindir}/adduser.${BPN}"
55ALTERNATIVE_TARGET[delgroup] = "${sbindir}/deluser.${BPN}"