blob: 04bc362dfb80e5fe2df70c330f34c6ad66369e36 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "CGI.pm is a stable, complete and mature solution for processing and preparing \
2HTTP requests and responses. Major features including processing form \
3submissions, file uploads, reading and writing cookies, query string generation \
4and manipulation, and processing and preparing HTTP headers."
5HOMEPAGE = "http://search.cpan.org/~leejo/CGI-4.28/lib/CGI.pod"
6SECTION = "libs"
7LICENSE = "Artistic-2.0 | GPL-2.0"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=415fc49abed2728f9480cd32c8d67beb"
10
11SRC_URI = "http://search.cpan.org/CPAN/authors/id/L/LE/LEEJO/CGI-${PV}.tar.gz"
12
Andrew Geissler69721092021-07-23 12:57:00 -040013SRC_URI[sha256sum] = "c67e732f3c96bcb505405fd944f131fe5c57b46e5d02885c00714c452bf14e60"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
15S = "${WORKDIR}/CGI-${PV}"
16
17inherit cpan ptest-perl
18
Patrick Williams213cb262021-08-07 19:21:33 -050019RDEPENDS:${PN} += "\
Andrew Geissler82c905d2020-04-13 13:39:40 -050020 libhtml-parser-perl \
21 perl-module-base \
22 perl-module-deprecate \
23 perl-module-if \
24"
25
Patrick Williams213cb262021-08-07 19:21:33 -050026do_install:prepend() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050027 # requires "-T" (taint) command line option
28 rm -rf ${B}/t/push.t
29 rm -rf ${B}/t/utf8.t
30 # tests building of docs
31 rm -rf ${B}/t/compiles_pod.t
32}
33
Patrick Williams213cb262021-08-07 19:21:33 -050034RDEPENDS:${PN}-ptest += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050035 libtest-deep-perl \
36 libtest-warn-perl \
37 perl-module-bytes \
38 perl-module-file-find \
39 perl-module-filehandle \
40 perl-module-findbin \
41 perl-module-lib \
42 perl-module-perlio \
43 perl-module-perlio-scalar \
44 perl-module-test-more \
45 perl-module-utf8 \
46"
47
Patrick Williams213cb262021-08-07 19:21:33 -050048RPROVIDES:${PN} += "perl-module-cgi"
Andrew Geissler82c905d2020-04-13 13:39:40 -050049
50BBCLASSEXTEND = "native"