blob: ea9dfed26191b954d3a7913b090dc14073fde1e4 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001# Copyright (C) 2020 Jens Rehsack <sno@netbsd.org>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "A module to implement some of AutoConf macros in pure perl"
5DESCRIPTION = "Config::AutoConf is intended to provide the same opportunities to Perl \
6developers as GNU Autoconf <http://www.gnu.org/software/autoconf/> does for \
7Shell developers."
8
9HOMEPAGE= "https://metacpan.org/release/Config-AutoConf"
10
11SECTION = "libs"
12LICENSE = "Artistic-1.0 | GPL-1.0+"
13
14LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \
Andrew Geissler97771a32021-03-05 15:23:11 -060015file://${COMMON_LICENSE_DIR}/GPL-1.0-or-later;md5=30c0b8a5048cc2f4be5ff15ef0d8cf61"
Brad Bishope42b3e32020-01-15 22:08:42 -050016
17SRC_URI = "${CPAN_MIRROR}/authors/id/R/RE/REHSACK/Config-AutoConf-${PV}.tar.gz"
18
Andrew Geissler8fc454f2020-12-11 16:27:59 -060019SRC_URI[md5sum] = "eeeab8cc93eef7dd2e2c343ecdf247b7"
20SRC_URI[sha256sum] = "304f66cc2653264c0fe127d21669e86d3d18cd72f2574d8f5131beec31a0a33e"
Patrick Williams213cb262021-08-07 19:21:33 -050021RDEPENDS:${PN} += "libcapture-tiny-perl"
22RDEPENDS:${PN} += "perl-module-base"
23RDEPENDS:${PN} += "perl-module-carp"
24RDEPENDS:${PN} += "perl-module-config"
25RDEPENDS:${PN} += "perl-module-constant"
26RDEPENDS:${PN} += "perl-module-file-basename"
27RDEPENDS:${PN} += "perl-module-file-spec"
28RDEPENDS:${PN} += "perl-module-file-temp"
29RDEPENDS:${PN} += "perl-module-extutils-cbuilder"
30RDEPENDS:${PN} += "perl-module-extutils-cbuilder-platform-unix"
31RDEPENDS:${PN} += "perl-module-scalar-util"
32RDEPENDS:${PN} += "perl-module-strict"
33RDEPENDS:${PN} += "perl-module-text-parsewords"
34RDEPENDS:${PN} += "perl-module-warnings"
35RRECOMMENDS:${PN} += "libfile-slurper-perl"
Brad Bishope42b3e32020-01-15 22:08:42 -050036
37S = "${WORKDIR}/Config-AutoConf-${PV}"
38
Andrew Geissler82c905d2020-04-13 13:39:40 -050039inherit cpan ptest-perl
Brad Bishope42b3e32020-01-15 22:08:42 -050040
41BBCLASSEXTEND = "native nativesdk"