blob: 4493a7e5e5f935f34fe8176b0a7da7b64cba0889 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Data::HexDump - Hexadecial Dumper"
2DESCRIPTION = "Dump in hexadecimal the content of a scalar. The result \
3is returned in a string. Each line of the result consists of the offset \
4in the source in the leftmost column of each line, followed by one or \
5more columns of data from the source in hexadecimal. The rightmost column \
6of each line shows the printable characters \
7(all others are shown as single dots).\
8"
9
10HOMEPAGE = "http://search.cpan.org/~ftassin/Data-HexDump-0.02/lib/Data/HexDump.pm"
11SECTION = "libs"
12
13LICENSE = "Artistic-1.0"
14LIC_FILES_CHKSUM = "file://lib/Data/HexDump.pm;beginline=215;endline=217;md5=bf1cd9373f8d1f85fe091ee069a480e9"
15
16DEPENDS = "perl"
17
18SRC_URI = "http://search.cpan.org/CPAN/authors/id/F/FT/FTASSIN/Data-HexDump-${PV}.tar.gz \
19 file://run-ptest \
20"
21SRC_URI[md5sum] = "467b7183d1062ab4a502b50c34e7d67f"
22SRC_URI[sha256sum] = "1a9d843e7f667c1c6f77c67af5d77e7462ff23b41937cb17454d03535cd9be70"
23
24S = "${WORKDIR}/Data-HexDump-${PV}"
25
Andrew Geisslerd688a012020-09-18 13:36:00 -050026inherit cpan ptest update-alternatives
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027
28do_install_ptest () {
29 install -d ${D}${PTEST_PATH}/t
30 install -m 0755 ${B}/t/* ${D}${PTEST_PATH}/t
31}
32
33BBCLASSEXTEND = "native"
Andrew Geisslerd688a012020-09-18 13:36:00 -050034
35ALTERNATIVES_PRIORITY = "100"
Patrick Williams213cb262021-08-07 19:21:33 -050036ALTERNATIVE:${PN} = "hexdump"
Andrew Geisslerd688a012020-09-18 13:36:00 -050037ALTERNATIVE_LINK_NAME[hexdump] = "${bindir}/hexdump"
38