blob: c328696b02470802e26f7046e660d4119324f6ad [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "A Perl DBI driver for SQLite"
2DESCRIPTION = "DBD::SQLite is a Perl DBI driver for SQLite, that includes the entire \
3thing in the distribution. So in order to get a fast transaction capable \
4RDBMS working for your perl project you simply have to install this \
5module, and nothing else. \
6"
7HOMEPAGE = "https://metacpan.org/release/DBD-SQLite"
8
9SECTION = "libs"
10LICENSE = "Artistic-1.0 | GPL-1.0+"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=1726e2117494ba3e13e1c3d93f795360"
12
13SRC_URI = "${CPAN_MIRROR}/authors/id/I/IS/ISHIGAKI/DBD-SQLite-${PV}.tar.gz \
14 file://sqlite-perl-test.pl \
15"
16
Patrick Williams213cb262021-08-07 19:21:33 -050017SRC_URI[sha256sum] = "0e84e831a50d547d2e634b66650455f1791f223495c9138db82d42360c691e61"
Brad Bishop26bdd442019-08-16 17:08:17 -040018
19UPSTREAM_CHECK_REGEX = "DBD\-SQLite\-(?P<pver>(\d+\.\d+))(?!_\d+).tar"
20
21S = "${WORKDIR}/DBD-SQLite-${PV}"
22
23DEPENDS += "libdbi-perl-native"
24
25inherit cpan ptest-perl
26
Patrick Williams213cb262021-08-07 19:21:33 -050027RDEPENDS:${PN} += "libdbi-perl \
Brad Bishop26bdd442019-08-16 17:08:17 -040028 sqlite3 \
29 perl-module-constant \
30 perl-module-locale \
31 perl-module-tie-hash \
32"
33
Patrick Williams213cb262021-08-07 19:21:33 -050034do_install:append() {
Brad Bishop26bdd442019-08-16 17:08:17 -040035 if [ ${PERL_DBM_TEST} = "1" ]; then
36 install -m 755 -D ${WORKDIR}/sqlite-perl-test.pl ${D}/${bindir}/sqlite-perl-test.pl
37 fi
38}
39
40do_install_ptest() {
41 cp -r ${B}/MANIFEST ${D}${PTEST_PATH}
42 chown -R root:root ${D}${PTEST_PATH}
43}
44
Patrick Williams213cb262021-08-07 19:21:33 -050045RDEPENDS:${PN}-ptest += " \
Brad Bishop26bdd442019-08-16 17:08:17 -040046 libtest-nowarnings-perl \
47 perl-module-lib \
48 perl-module-encode \
49 perl-module-file-spec \
50 perl-module-file-spec-functions \
51 perl-module-findbin \
52 perl-module-test-more \
53 "
54
55BBCLASSEXTEND = "native"