blob: 5e869c8112d590eea751e0a5a559e37c873b47dd [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "ExtUtils::CppGuess - guess C++ compiler and flags"
2DESCRIPTION = "ExtUtils::CppGuess attempts to guess the system's C++ \
3compiler that is compatible with the C compiler that your perl was built \
4with. \
5It can generate the necessary options to the Module::Build constructor or \
6to ExtUtils::MakeMaker's WriteMakefile function."
7SECTION = "libs"
8
9HOMEPAGE = "http://search.cpan.org/~smueller/ExtUtils-CppGuess/"
10
11LICENSE = "Artistic-1.0 | GPL-1.0+"
12LIC_FILES_CHKSUM = "file://README;beginline=81;endline=84;md5=84c0390b90ea8c6702ce659b67bed699"
13
14SRC_URI = "${CPAN_MIRROR}/authors/id/E/ET/ETJ/ExtUtils-CppGuess-${PV}.tar.gz"
Andrew Geissler69721092021-07-23 12:57:00 -040015SRC_URI[sha256sum] = "f96c48984eb6d8efb7d933b34f361d0c8b38335e3e5382e9aeccc0aa519a002c"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016
17S = "${WORKDIR}/ExtUtils-CppGuess-${PV}"
18
19inherit cpan
20
21do_install () {
22 cpan_do_install
23}
24
Patrick Williams213cb262021-08-07 19:21:33 -050025RDEPENDS:${PN} = " libcapture-tiny-perl \
Andrew Geissler82c905d2020-04-13 13:39:40 -050026 perl-module-scalar-util \
27 perl-module-io-file \
28 perl-module-extutils-makemaker \
29 perl-module-file-spec \
30 perl-module-exporter \
31 perl-module-carp \
32 perl-module-file-temp \
33 perl-module-lib \
34"
35
36BBCLASSEXTEND = "native"