blob: 4a2cb73e86a412922daf1fa1d523b972169ee1bd [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "A simple, sane and efficient module to slurp a file"
2DESCRIPTION = "This module provides functions for fast and correct slurping and spewing. \
3All functions are optionally exported. All functions throw exceptions on \
4errors, write functions don't return any meaningful value."
5
6SECTION = "libs"
7LICENSE = "Artistic-1.0 | GPL-1.0+"
8
9HOMEPAGE= "https://metacpan.org/release/File-Slurper"
10
11LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \
Andrew Geissler97771a32021-03-05 15:23:11 -060012file://${COMMON_LICENSE_DIR}/GPL-1.0-or-later;md5=30c0b8a5048cc2f4be5ff15ef0d8cf61"
Brad Bishope42b3e32020-01-15 22:08:42 -050013
14SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/File-Slurper-${PV}.tar.gz"
15
16SRC_URI[md5sum] = "5742c63096392dfee50b8db314bcca18"
17SRC_URI[sha256sum] = "4efb2ea416b110a1bda6f8133549cc6ea3676402e3caf7529fce0313250aa578"
Patrick Williams213cb262021-08-07 19:21:33 -050018RDEPENDS:${PN} = " \
Brad Bishope42b3e32020-01-15 22:08:42 -050019 perl-module-carp \
20 perl-module-encode \
21 perl-module-exporter \
22 perl-module-perlio \
23 perl-module-perlio-encoding \
24 perl-module-strict \
25 perl-module-warnings \
26"
27
Patrick Williams213cb262021-08-07 19:21:33 -050028RDEPENDS:${PN}-ptest += "libtest-warnings-perl \
Brad Bishope42b3e32020-01-15 22:08:42 -050029 perl-module-test-more \
30 "
31
32S = "${WORKDIR}/File-Slurper-${PV}"
33
Andrew Geissler82c905d2020-04-13 13:39:40 -050034inherit cpan ptest-perl
Brad Bishope42b3e32020-01-15 22:08:42 -050035
36BBCLASSEXTEND = "native"