blob: a0be629683ee33f13c6844e6946b2bcaaf65e2d4 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Import::Into - import packages into other packages"
2DESCRIPTION = "Writing exporters is a pain. Some use \"Exporter\", some use \
3\"Sub::Exporter\", some use \"Moose::Exporter\", some use \
4\"Exporter::Declare\"... and some things are pragmas.\
5\
6Exporting on someone else's behalf is harder. The exporters don't provide a \
7consistent API for this, and pragmas need to have their import method called \
8directly, since they effect the current unit of compilation. \
9\
10\"Import::Into\" provides global methods to make this painless."
11
12SECTION = "libs"
13
14HOMEPAGE = "https://metacpan.org/pod/Import-Into/"
15
16LICENSE = "Artistic-1.0 | GPL-1.0+"
17LIC_FILES_CHKSUM = "file://README;beginline=209;endline=223;md5=3cf363f1e405dea6db2c6cd0ef23680c"
18
19SRC_URI = "${CPAN_MIRROR}/authors/id/E/ET/ETHER/Import-Into-${PV}.tar.gz"
20SRC_URI[md5sum] = "70f2f3b08a5b706ee382a8448c346cb1"
21SRC_URI[sha256sum] = "decb259bc2ff015fe3dac85e4a287d4128e9b0506a0b2c5fa7244836a68b1084"
22
23S = "${WORKDIR}/Import-Into-${PV}"
24
25inherit cpan
26
Patrick Williams213cb262021-08-07 19:21:33 -050027RDEPENDS:${PN} = " libmodule-runtime-perl \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050028 perl-module-strict \
29 perl-module-warnings \
30"
31
32BBCLASSEXTEND = "native"