blob: fd398a0fe27101ca06d0bb86ca3f7070da4916ae [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "MIME::Types - Definition of MIME types"
2DESCRIPTION = "MIME types are used in MIME compliant lines, for instance \
3as part of e-mail and HTTP traffic, to indicate the type of content which \
4is transmitted. Sometimes real knowledge about a mime-type is need.\
5\n\
6This module maintains a set of MIME::Type objects, which each describe \
7one known mime type."
8HOMEPAGE = "http://search.cpan.org/~markov/MIME-Types-${PV}"
9SECTION = "libraries"
10
11LICENSE = "Artistic-1.0|GPLv1+"
12LIC_FILES_CHKSUM = "file://META.yml;beginline=11;endline=11;md5=963ce28228347875ace682de56eef8e8"
13
14SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/MIME-Types-${PV}.tar.gz \
15 file://run-ptest \
16 "
17SRC_URI[md5sum] = "6f1441addab947137bac92c379a47ba3"
18SRC_URI[sha256sum] = "e04ed7d42f1ff3150a303805f2689c28f80b92c511784d4641cb7f040d3e8ff6"
19
20S = "${WORKDIR}/MIME-Types-${PV}"
21
22inherit cpan ptest
23
Patrick Williams213cb262021-08-07 19:21:33 -050024RDEPENDS:${PN} = "\
Brad Bishop316dfdd2018-06-25 12:45:53 -040025 perl-module-base \
26 perl-module-file-basename \
27 perl-module-file-spec \
28 perl-module-overload \
29"
30
Patrick Williams213cb262021-08-07 19:21:33 -050031RDEPENDS:${PN}-ptest = "perl-module-lib perl-module-test-more"
Brad Bishop316dfdd2018-06-25 12:45:53 -040032#RSUGGESTS_${PN}-ptest = "libmojo-base-perl"
33
34do_install () {
35 cpan_do_install
36 install -d ${D}${bindir}
37 install -m 755 ${S}/bin/collect-types ${D}${bindir}/collect-types
38}
39
40do_install_ptest () {
41 cp -r ${B}/t ${D}${PTEST_PATH}
42}