blob: bb950b80de2c5fd4c1e8f87d17a759e78d220e6d [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Module::Runtime - runtime module handling"
2DESCRIPTION = "The functions exported by this module deal with runtime \
3handling of Perl modules, which are normally handled at compile time. This \
4module avoids using any other modules, so that it can be used in low-level \
5infrastructure. \
6The parts of this module that work with module names apply the same syntax \
7that is used for barewords in Perl source. In principle this syntax can vary \
8between versions of Perl, and this module applies the syntax of the Perl on \
9which it is running. In practice the usable syntax hasn't changed yet, but \
10there's a good chance of it changing in Perl 5.18. \
11The functions of this module whose purpose is to load modules include \
12workarounds for three old Perl core bugs regarding require. These workarounds \
13are applied on any Perl version where the bugs exist, except for a case where \
14one of the bugs cannot be adequately worked around in pure Perl."
15SECTION = "libs"
16
17HOMEPAGE = "http://search.cpan.org/~zefram/Module-Runtime/"
18
19LICENSE = "Artistic-1.0 | GPL-1.0+"
20LIC_FILES_CHKSUM = "file://README;beginline=36;endline=44;md5=9416434672a57853d6181f3da9094963"
21
22SRCNAME = "Module-Runtime"
23SRC_URI = "${CPAN_MIRROR}/authors/id/Z/ZE/ZEFRAM/${SRCNAME}-${PV}.tar.gz"
24SRC_URI[md5sum] = "d3d47222fa2e3dfcb4526f6cc8437b20"
25SRC_URI[sha256sum] = "68302ec646833547d410be28e09676db75006f4aa58a11f3bdb44ffe99f0f024"
26
27UPSTREAM_CHECK_REGEX = "Module\-Runtime\-(?P<pver>(\d+\.\d+)).tar"
28
29S = "${WORKDIR}/${SRCNAME}-${PV}"
30
31inherit cpan
32
Patrick Williams213cb262021-08-07 19:21:33 -050033RDEPENDS:${PN} = " perl-module-test-more \
Brad Bishop316dfdd2018-06-25 12:45:53 -040034 perl-module-strict \
35"
36
37BBCLASSEXTEND = "native"