blob: 75e1623f945fe4d6cbcf2718c9101f21b861f627 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Test::Deep - Extremely flexible deep comparison"
2DESCRIPTION = "If you don't know anything about automated testing in Perl \
3then you should probably read about Test::Simple and Test::More before \
4preceding. Test::Deep uses the Test::Builder framework. \
5\
6Test::Deep gives you very flexible ways to check that the result you got is \
7the result you were expecting. At its simplest it compares two structures \
8by going through each level, ensuring that the values match, that arrays and \
9hashes have the same elements and that references are blessed into the \
10correct class. It also handles circular data structures without getting \
11caught in an infinite loop. \
12\
13Where it becomes more interesting is in allowing you to do something besides \
14simple exact comparisons. With strings, the \'eq\' operator checks that 2 \
15strings are exactly equal but sometimes that's not what you want. When you \
16don't know exactly what the string should be but you do know some things \
17about how it should look, \'eq\' is no good and you must use pattern matching \
18instead. Test::Deep provides pattern matching for complex data structures \
19distribution."
20
21SECTION = "libs"
22
23HOMEPAGE = "http://github.com/rjbs/Test-Deep/"
24
25LICENSE = "Artistic-1.0 | GPL-1.0+"
26LIC_FILES_CHKSUM = "file://lib/Test/Deep.pm;beginline=1817;endline=1826;md5=a897a42bafc3422cab17c2eb94f87a7c"
27
28SRC_URI = "${CPAN_MIRROR}/authors/id/R/RJ/RJBS/Test-Deep-${PV}.tar.gz"
29SRC_URI[md5sum] = "d466e471108f7f7a5df3802cb13761ac"
30SRC_URI[sha256sum] = "4064f494f5f62587d0ae501ca439105821ee5846c687dc6503233f55300a7c56"
31
32UPSTREAM_CHECK_REGEX = "Test\-Deep\-(?P<pver>(\d+\.\d+))(?!_\d+).tar"
33
34S = "${WORKDIR}/Test-Deep-${PV}"
35
36inherit cpan ptest-perl
37
Patrick Williams213cb262021-08-07 19:21:33 -050038RDEPENDS:${PN} += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050039 perl-module-dynaloader \
40 perl-module-exporter \
41 perl-module-fcntl \
42 perl-module-list-util \
43 perl-module-scalar-util \
44 perl-module-strict \
45 perl-module-vars \
46 perl-module-warnings \
47"
48
Patrick Williams213cb262021-08-07 19:21:33 -050049RDEPENDS:${PN}-ptest += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050050 perl-module-if \
51 perl-module-lib \
52 perl-module-test-more \
53 perl-module-test-tester \
54"
55
56BBCLASSEXTEND = "native"