blob: b20668331dd364b3c7bfda580a9b08160bf63ad7 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Make sure you didn't emit any warnings while testing"
2DESCRIPTION = "In general, your tests shouldn't produce warnings. This \
3modules causes any warnings to be captured and stored. It automatically \
4adds an extra test that will run when your script ends to check that there \
5were no warnings. If there were any warings, the test will give a \\"not ok\\" \
6and diagnostics of where, when and what the warning was, including a stack \
7trace of what was going on when the it occurred.\
8\
9If some of your tests are supposed to produce warnings then you should \
10be capturing and checking them with Test::Warn, that way \
11Test::NoWarnings will not see them and so not complain.\
12\
13The test is run by an \\"END\\" block in Test::NoWarnings. It will not be \
14run when any forked children exit."
15
16SECTION = "libs"
17LICENSE = "LGPL-2.1"
18
19HOMEPAGE= "https://metacpan.org/release/Test-NoWarnings"
20
21LIC_FILES_CHKSUM = "file://LICENSE;md5=d8045f3b8f929c1cb29a1e3fd737b499"
22
23CPAN_PACKAGE = "Test-NoWarnings"
24CPAN_AUTHOR = "ADAMK"
25
26SRC_URI = "${CPAN_MIRROR}/authors/id/A/AD/${CPAN_AUTHOR}/${CPAN_PACKAGE}-${PV}.tar.gz"
27
28SRC_URI[md5sum] = "682ed043f7d3e38f3dfd8745fd21c49a"
29SRC_URI[sha256sum] = "638a57658cb119af1fe5b15e73d47c2544dcfef84af0c6b1b2e97f08202b686c"
30
Patrick Williams213cb262021-08-07 19:21:33 -050031RDEPENDS:${PN} += "perl-module-test-builder perl-module-test-more perl-module-test-tester"
Brad Bishop26bdd442019-08-16 17:08:17 -040032
33S = "${WORKDIR}/${CPAN_PACKAGE}-${PV}"
34
35inherit cpan ptest-perl
36
37BBCLASSEXTEND = "native nativesdk"