blob: 07cc99860df226a6a5c0bfa3ae7fd37e599e1916 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Wraps the best available JSON implementation available in a common interface"
2DESCRIPTION = "Anyjson loads whichever is the fastest JSON module installed and \
3provides a uniform API regardless of which JSON implementation is used."
4HOMEPAGE = "https://bitbucket.org/runeh/anyjson"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=989aa97e73c912a83a3c873fa11deb08"
7
Andrew Geisslerd221e032020-07-10 16:13:21 -05008inherit pypi setuptools3 ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
Patrick Williams213cb262021-08-07 19:21:33 -050014RDEPENDS:${PN}-ptest += " \
Andrew Geisslerd221e032020-07-10 16:13:21 -050015 ${PYTHON_PN}-pytest \
16 ${PYTHON_PN}-nose \
17"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
Andrew Geissler82c905d2020-04-13 13:39:40 -050023
24SRC_URI[md5sum] = "2ea28d6ec311aeeebaf993cb3008b27c"
25SRC_URI[sha256sum] = "37812d863c9ad3e35c0734c42e0bf0320ce8c3bed82cd20ad54cb34d158157ba"
26
Patrick Williams213cb262021-08-07 19:21:33 -050027RDEPENDS:${PN} += "${PYTHON_PN}-simplejson"