blob: 0cbeca21c7833caa36d3b39c6ef4d633201f4981 [file] [log] [blame]
Andrew Geissler69721092021-07-23 12:57:00 -04001# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "``aspectlib`` is an aspect-oriented programming, monkey-patch and decorators library. It is useful when changing"
5HOMEPAGE = "https://github.com/ionelmc/python-aspectlib"
6LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=d58b3f20fd10347a9458b8a03793b62e"
8
9SRC_URI[sha256sum] = "d275ec82c4c2712e564bb760e4accff8f061f648e38774feabeb8b241cf3a4aa"
10
11inherit ptest pypi setuptools3
12
13SRC_URI += "file://run-ptest \
14 file://0001-Remove-tornado-6-test-constraint.-Ref-15.patch \
15 "
16
17do_install_ptest() {
18 install -d ${D}${PTEST_PATH}/tests
19 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
20}
21
Patrick Williams213cb262021-08-07 19:21:33 -050022RDEPENDS:${PN}-ptest += "\
Andrew Geissler69721092021-07-23 12:57:00 -040023 python3-tornado \
24 python3-process-tests \
25"
26
Patrick Williams213cb262021-08-07 19:21:33 -050027RDEPENDS:${PN} += "python3-core python3-fields"
Andrew Geissler69721092021-07-23 12:57:00 -040028
29BBCLASSEXTEND = "native nativesdk"