blob: e07fa9899242d7412de80ef68cf975dc1fda4004 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "httplib2 caching for requests"
2HOMEPAGE = "https://pypi.org/project/CacheControl/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=6dc7e1b428eda03d850209fdbd6c71f1"
5
6# On PyPi, this is "CacheControl", rather than "cachecontrol", so we need to
7# override PYPI_PACKAGE so fetch succeeds.
8PYPI_PACKAGE = "CacheControl"
9
10SRC_URI[md5sum] = "5890b797f9b48b2b4cd1448cca89e396"
11SRC_URI[sha256sum] = "be9aa45477a134aee56c8fac518627e1154df063e85f67d4f83ce0ccc23688e8"
12
13inherit pypi setuptools3
14
Patrick Williams213cb262021-08-07 19:21:33 -050015RDEPENDS:${PN} += "\
Andrew Geissler82c905d2020-04-13 13:39:40 -050016 python3-crypt \
17 python3-datetime \
18 python3-email \
19 python3-lockfile \
20 python3-json \
21 python3-logging \
22 python3-msgpack \
23 python3-netclient \
24 python3-pickle \
25 python3-requests \
26 python3-urllib3 \
27"
28
29BBCLASSEXTEND = "native nativesdk"