blob: 73bdd7007ba853990a52f98b19a0d806bf3a306e [file] [log] [blame]
Andrew Geissler69721092021-07-23 12:57:00 -04001# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "execnet: rapid multi-Python deployment"
5HOMEPAGE = "https://execnet.readthedocs.io/en/latest/"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e"
8
9DEPENDS += "python3-pip-native"
10
11SRC_URI += "file://run-ptest \
12 "
13SRC_URI[sha256sum] = "8f694f3ba9cc92cab508b152dcfe322153975c29bda272e2fd7f3f00f36e47c5"
14
15inherit ptest pypi setuptools3
16
17do_install_ptest() {
18 install -d ${D}${PTEST_PATH}/tests
19 cp -rf ${S}/testing/* ${D}${PTEST_PATH}/tests/
20}
21
Patrick Williams213cb262021-08-07 19:21:33 -050022RDEPENDS:${PN}-ptest += "\
Andrew Geissler69721092021-07-23 12:57:00 -040023 python3-pytest \
24"
25
Patrick Williams213cb262021-08-07 19:21:33 -050026RDEPENDS:${PN} += "python3-core python3-crypt python3-ctypes python3-fcntl python3-io python3-shell python3-threading"
Andrew Geissler69721092021-07-23 12:57:00 -040027
28BBCLASSEXTEND = "native nativesdk"