blob: a8bc0c10d4e922a0cbbda4d7bd65b62cc80ffdef [file] [log] [blame]
Andrew Geissler69721092021-07-23 12:57:00 -04001# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Fastest Python implementation of JSON schema"
5HOMEPAGE = "https://github.com/seznam/python-fastjsonschema"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=18950e8362b69c0c617b42b8bd8e7532"
8
9SRCREV = "1e214911fe83dbaeea3d50dfb3a539118de8a442"
10PYPI_SRC_URI = "git://github.com/horejsek/python-fastjsonschema;protocol=https;branch=master"
11
12SRC_URI += "file://run-ptest"
13
14inherit ptest pypi setuptools3
15
16S = "${WORKDIR}/git"
17
18do_install_ptest() {
19 install -d ${D}${PTEST_PATH}/tests
20 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
21}
22
Patrick Williams213cb262021-08-07 19:21:33 -050023RDEPENDS:${PN}-ptest += "\
Andrew Geissler69721092021-07-23 12:57:00 -040024 python3-colorama \
25 python3-jsonschema \
26 python3-pylint \
27 python3-pytest \
28 python3-pytest-benchmark \
29 python3-pytest-cache \
30"
Patrick Williams213cb262021-08-07 19:21:33 -050031RDEPENDS:${PN} += "\
Andrew Geissler69721092021-07-23 12:57:00 -040032 python3-core \
33 python3-urllib3 \
34 python3-numbers \
35 python3-pickle \
36 "
37
38BBCLASSEXTEND = "native nativesdk"