blob: 8b39679e458a06c8afb09049c72abd62a73636e8 [file] [log] [blame]
Andrew Geisslerc87764f2020-06-27 00:16:32 -05001SUMMARY = "IPy - class and tools for handling of IPv4 and IPv6 addresses and networks"
2DESCRIPTION = "IPy is a Python module for handling IPv4 and IPv6 Addresses and Networks \
3in a fashion similar to perl's Net::IP and friends. The IP class allows \
4a comfortable parsing and handling for most notations in use for IPv4 \
5and IPv6 Addresses and Networks."
6SECTION = "devel/python"
7HOMEPAGE = "https://github.com/autocracy/python-ipy"
8
9LICENSE = "BSD-3-Clause"
10LIC_FILES_CHKSUM = "file://COPYING;md5=848d24919845901b4f48bae5f13252e6"
11
Andrew Geisslereef63862021-01-29 15:58:13 -060012SRC_URI[md5sum] = "d6cf83e7f418ebbd23324ba1c658b907"
13SRC_URI[sha256sum] = "edeca741dea2d54aca568fa23740288c3fe86c0f3ea700344571e9ef14a7cc1a"
Andrew Geisslerc87764f2020-06-27 00:16:32 -050014
15inherit pypi setuptools3 ptest
16
17SRC_URI += " \
18 file://run-ptest \
19"
20
Patrick Williams213cb262021-08-07 19:21:33 -050021RDEPENDS:${PN}-ptest += " \
Andrew Geisslerc87764f2020-06-27 00:16:32 -050022 ${PYTHON_PN}-pytest \
23"
24
25do_install_ptest() {
26 install -d ${D}${PTEST_PATH}/test/
27 cp -rf ${S}/test/* ${D}${PTEST_PATH}/test
28}
29
30PYPI_PACKAGE = "IPy"
31
32BBCLASSEXTEND = "native"