blob: 2ed5d917092c0f637d0ca62050600cacc5ad4bd3 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Utility library to parse, compare, simplify and normalize license expressions"
2HOMEPAGE = "https://github.com/nexB/license-expression"
3
4LICENSE = "Apache-2.0"
Andrew Geissler69721092021-07-23 12:57:00 -04005LIC_FILES_CHKSUM = "file://apache-2.0.LICENSE;md5=9429839cdc4b292ff46e88b524c6e0c9"
Brad Bishope42b3e32020-01-15 22:08:42 -05006
Andrew Geissler69721092021-07-23 12:57:00 -04007SRC_URI[sha256sum] = "9de87a427c9a449eee7913472fb9ed03b63036295547369fdbf95f76a8b924b2"
Brad Bishope42b3e32020-01-15 22:08:42 -05008
Andrew Geisslerc87764f2020-06-27 00:16:32 -05009inherit pypi ptest setuptools3
Brad Bishope42b3e32020-01-15 22:08:42 -050010
Andrew Geissler69721092021-07-23 12:57:00 -040011DEPENDS += "\
12 ${PYTHON_PN}-setuptools-scm-native \
13 ${PYTHON_PN}-wheel-native \
14"
15
Patrick Williams213cb262021-08-07 19:21:33 -050016RDEPENDS:${PN} += "\
Brad Bishope42b3e32020-01-15 22:08:42 -050017 ${PYTHON_PN}-booleanpy \
Andrew Geissler69721092021-07-23 12:57:00 -040018"
Brad Bishope42b3e32020-01-15 22:08:42 -050019
20BBCLASSEXTEND = "native nativesdk"
Andrew Geissler82c905d2020-04-13 13:39:40 -050021
22SRC_URI += " \
23 file://run-ptest \
24"
25
Patrick Williams213cb262021-08-07 19:21:33 -050026RDEPENDS:${PN}-ptest += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050027 ${PYTHON_PN}-pytest \
28"
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}/tests
32 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
33}