blob: 1a494af5af5df76180b592c21c33cb662aaef5d3 [file] [log] [blame]
Andrew Geissler69721092021-07-23 12:57:00 -04001SUMMARY = "Optional static typing for Python 3 and 2 (PEP 484)"
2HOMEPAGE = "https://github.com/python/mypy"
3LICENSE = "MIT & Python-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=17b7180fcfc43c4e70c07c71588604c4"
5
6PYPI_PACKAGE = "mypy"
7
8inherit pypi setuptools3
9
10SRC_URI[sha256sum] = "704098302473cb31a218f1775a873b376b30b4c18229421e9e9dc8916fd16150"
11
12BBCLASSEXTEND = "native"
13
Patrick Williams213cb262021-08-07 19:21:33 -050014RDEPENDS:${PN} += " \
Andrew Geissler69721092021-07-23 12:57:00 -040015 ${PYTHON_PN}-mypy-extensions \
16 ${PYTHON_PN}-typed-ast \
17 ${PYTHON_PN}-typing-extensions \
18 ${PYTHON_PN}-json \
19 ${PYTHON_PN}-compression \
20 ${PYTHON_PN}-pprint \
21 ${PYTHON_PN}-difflib \
22 ${PYTHON_PN}-toml \
23"