blob: 2bf55cbaffc1a4be3833308d31732a8181e9a1e3 [file] [log] [blame]
Andrew Geisslerc87764f2020-06-27 00:16:32 -05001SUMMARY = "Parse strings using a specification based on the Python format() syntax"
2HOMEPAGE = "https://github.com/r1chardj0n3s/parse"
3LICENSE = "MIT"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05004LIC_FILES_CHKSUM = "file://LICENSE;md5=8ab458ad281b60e6f1b39b3feafbfc05"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05005
Andrew Geisslereef63862021-01-29 15:58:13 -06006SRC_URI[sha256sum] = "9ff82852bcb65d139813e2a5197627a94966245c897796760a3a2a8eb66f020b"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05007
8inherit pypi setuptools3 ptest
9
Patrick Williams213cb262021-08-07 19:21:33 -050010RDEPENDS:${PN} += "\
Andrew Geisslerc87764f2020-06-27 00:16:32 -050011 ${PYTHON_PN}-datetime \
12 ${PYTHON_PN}-logging \
13 "
14
15SRC_URI += " \
16 file://run-ptest \
17"
18
Patrick Williams213cb262021-08-07 19:21:33 -050019RDEPENDS:${PN}-ptest += " \
Andrew Geisslerc87764f2020-06-27 00:16:32 -050020 ${PYTHON_PN}-pytest \
21"
22
23do_install_ptest() {
24 cp -f ${S}/test_parse.py ${D}${PTEST_PATH}/
25}