blob: 86f29e119d5a505efa4d5ec861bc743505131d17 [file] [log] [blame]
Andrew Geissler32b11992021-03-31 13:37:05 -05001SUMMARY = "Load, configure, and compose WSGI applications and servers"
2HOMEPAGE = "https://pylonsproject.org/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://license.txt;md5=1798f29d55080c60365e6283cb49779c"
5
6inherit pypi
7PYPI_PACKAGE = "PasteDeploy"
8
9SRC_URI[sha256sum] = "6dead6ab9823a85d585ef27f878bc647f787edb9ca8da0716aa9f1261b464817"
10
11S = "${WORKDIR}/PasteDeploy-${PV}"
12
13inherit setuptools3
14
15# Uncomment this line to enable all the optional features.
16#PACKAGECONFIG ?= "paste docs"
17PACKAGECONFIG[paste] = ",,,python3-paste"
18PACKAGECONFIG[docs] = ",,,python3-sphinx python3-pylons-sphinx-themes"
19
20DEPENDS= "python3 python3-setuptools-scm-native python3-pytest-runner-native"
Patrick Williams213cb262021-08-07 19:21:33 -050021RDEPENDS:${PN} += "python3-core python3-misc python3-netclient python3-pkgutil python3-setuptools python3-threading python3-core"