blob: 486e70c8fdb7c234819b640e7a027191faebbf52 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A Python implementation of Google's Encoded Polyline Algorithm Format"
2HOMEPAGE = "https://pypi.org/project/polyline/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=0fbd13500cabd06dd751ba6b2be304c6"
5
6SRC_URI[md5sum] = "b97c57378605c4a856c437569f95a0cb"
7SRC_URI[sha256sum] = "7c7f89d09a09c7b6161bdbfb4fd304b186fc7a2060fa4f31cb3f61c646a5c074"
8
9inherit pypi setuptools3 ptest
10
Patrick Williams213cb262021-08-07 19:21:33 -050011RDEPENDS:${PN} += "python3-six"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
13BBCLASSEXTEND = "native nativesdk"
14
15SRC_URI += " \
16 file://run-ptest \
17"
18
Patrick Williams213cb262021-08-07 19:21:33 -050019RDEPENDS:${PN}-ptest += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050020 ${PYTHON_PN}-pytest \
21"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/test
25 cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
26}