blob: b43529cc95cc96a4cf08f2bad06b26ef0d066fd4 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "Protocol Buffers"
2HOMEPAGE = "https://developers.google.com/protocol-buffers/"
3SECTION = "devel/python"
4
Brad Bishopd7bf8c12018-02-25 22:55:05 -05005LICENSE = "BSD-3-Clause"
Brad Bishop0f291cc2019-09-01 15:16:57 -04006LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=19e8f490f9526b1de84f8d949cfcfd4e"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05007
Andrew Geisslerc87764f2020-06-27 00:16:32 -05008inherit pypi setuptools3
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009
Andrew Geissler69721092021-07-23 12:57:00 -040010SRC_URI[sha256sum] = "72804ea5eaa9c22a090d2803813e280fb273b62d5ae497aaf3553d141c4fdd7b"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011
12# http://errors.yoctoproject.org/Errors/Details/184715/
13# Can't find required file: ../src/google/protobuf/descriptor.proto
14CLEANBROKEN = "1"
15
16UPSTREAM_CHECK_REGEX = "protobuf/(?P<pver>\d+(\.\d+)+)/"
Brad Bishop316dfdd2018-06-25 12:45:53 -040017
Andrew Geisslerc87764f2020-06-27 00:16:32 -050018DEPENDS += "protobuf"
19
Patrick Williams213cb262021-08-07 19:21:33 -050020RDEPENDS:${PN} += " \
Brad Bishop316dfdd2018-06-25 12:45:53 -040021 ${PYTHON_PN}-datetime \
22 ${PYTHON_PN}-json \
23 ${PYTHON_PN}-logging \
24 ${PYTHON_PN}-netclient \
25 ${PYTHON_PN}-numbers \
26 ${PYTHON_PN}-pkgutil \
27 ${PYTHON_PN}-six \
28 ${PYTHON_PN}-unittest \
29"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050030
31# For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools)
Brad Bishop19323692019-04-05 15:28:33 -040032BBCLASSEXTEND = "native nativesdk"
33
Andrew Geisslerc87764f2020-06-27 00:16:32 -050034DISTUTILS_BUILD_ARGS += "--cpp_implementation"
35DISTUTILS_INSTALL_ARGS += "--cpp_implementation"
36
Patrick Williams213cb262021-08-07 19:21:33 -050037do_compile:prepend:class-native () {
Andrew Geisslerc87764f2020-06-27 00:16:32 -050038 export KOKORO_BUILD_NUMBER="1"
39}