blob: ff1155eeb144a4c306c8c9436f0e879498f10385 [file] [log] [blame]
Andrew Geisslerc87764f2020-06-27 00:16:32 -05001SUMMARY = "Run a subprocess in a pseudo terminal"
2HOMEPAGE = "http://ptyprocess.readthedocs.io/en/latest/"
3SECTION = "devel/python"
4LICENSE = "ISC"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=cfdcd51fa7d5808da4e74346ee394490"
6
7SRCNAME = "ptyprocess"
8
Andrew Geisslereef63862021-01-29 15:58:13 -06009SRC_URI[sha256sum] = "5c5d0a3b48ceee0b48485e0c26037c0acd7d29765ca3fbb5cb3831d347423220"
Andrew Geisslerc87764f2020-06-27 00:16:32 -050010
Brad Bishopd7bf8c12018-02-25 22:55:05 -050011inherit pypi setuptools3
Andrew Geisslerc87764f2020-06-27 00:16:32 -050012
13UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/ptyprocess"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
Patrick Williams213cb262021-08-07 19:21:33 -050017RDEPENDS:${PN} = "\
Andrew Geisslerc87764f2020-06-27 00:16:32 -050018 ${PYTHON_PN}-core \
19 ${PYTHON_PN}-fcntl \
20 ${PYTHON_PN}-terminal \
21 ${PYTHON_PN}-resource \
22"
23
24BBCLASSEXTEND = "native nativesdk"
25
26inherit ptest
27
28SRC_URI += " \
29 file://run-ptest \
30"
31
Patrick Williams213cb262021-08-07 19:21:33 -050032RDEPENDS:${PN}-ptest += " \
Andrew Geisslerc87764f2020-06-27 00:16:32 -050033 ${PYTHON_PN}-pytest \
34 ${PYTHON_PN}-fcntl \
35 ${PYTHON_PN}-terminal \
36 ${PYTHON_PN}-resource \
37"
38
39do_install_ptest() {
40 install -d ${D}${PTEST_PATH}/tests
41 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
42}