blob: d6a2749c24f50de96d50b1ea9d7ecd40752ff79f [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "A collection of ASN.1-based protocols modules."
2DESCRIPTION = "A collection of ASN.1 modules expressed in form of pyasn1\
3 classes. Includes protocols PDUs definition (SNMP, LDAP etc.) and various\
4 data structures (X.509, PKCS etc.)."
5HOMEPAGE = "https://github.com/etingof/pyasn1-modules"
6LICENSE = "BSD-2-Clause"
Brad Bishop26bdd442019-08-16 17:08:17 -04007LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a14482d15c2249de3b6f0e8a47e021fd"
Brad Bishop316dfdd2018-06-25 12:45:53 -04008
Andrew Geisslerd221e032020-07-10 16:13:21 -05009SRC_URI[md5sum] = "107e1ece7d0a41d782f69f8a95a4d9bc"
10SRC_URI[sha256sum] = "905f84c712230b2c592c19470d3ca8d552de726050d1d1716282a1f6146be65e"
Brad Bishop316dfdd2018-06-25 12:45:53 -040011
Andrew Geisslerd221e032020-07-10 16:13:21 -050012inherit pypi ptest setuptools3
Brad Bishop316dfdd2018-06-25 12:45:53 -040013
Patrick Williams213cb262021-08-07 19:21:33 -050014RDEPENDS:${PN} = "${PYTHON_PN}-pyasn1"
Brad Bishop316dfdd2018-06-25 12:45:53 -040015
16BBCLASSEXTEND = "native nativesdk"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
18SRC_URI += " \
19 file://run-ptest \
20"
21
Patrick Williams213cb262021-08-07 19:21:33 -050022RDEPENDS:${PN}-ptest += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050023 ${PYTHON_PN}-pytest \
24"
25
26do_install_ptest() {
27 install -d ${D}${PTEST_PATH}/tests
28 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
29}