blob: 17975ff5d3885cb5f804b333d5b13bcd2da86e92 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Python driver for MongoDB <http://www.mongodb.org>"
2DESCRIPTION = "\
3The PyMongo distribution contains tools for interacting with MongoDB \
4database from Python. The bson package is an implementation of the BSON \
5format for Python. The pymongo package is a native Python driver for \
6MongoDB. The gridfs package is a gridfs implementation on top of pymongo."
7HOMEPAGE = "http://github.com/mongodb/mongo-python-driver"
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
10
Patrick Williams213cb262021-08-07 19:21:33 -050011SRC_URI[sha256sum] = "b88d1742159bc93a078733f9789f563cef26f5e370eba810476a71aa98e5fbc2"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
13inherit pypi setuptools3
14
15PACKAGES =+ "${PYTHON_PN}-bson"
16
Patrick Williams213cb262021-08-07 19:21:33 -050017FILES:${PYTHON_PN}-bson = "${PYTHON_SITEPACKAGES_DIR}/bson/*"
Andrew Geissler82c905d2020-04-13 13:39:40 -050018
Patrick Williams213cb262021-08-07 19:21:33 -050019RDEPENDS:${PYTHON_PN}-bson += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050020 ${PYTHON_PN}-datetime \
21 ${PYTHON_PN}-json \
22 ${PYTHON_PN}-netclient \
23 ${PYTHON_PN}-numbers \
24 ${PYTHON_PN}-threading \
25"
26
Patrick Williams213cb262021-08-07 19:21:33 -050027RDEPENDS:${PN} += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050028 ${PYTHON_PN}-bson \
29 ${PYTHON_PN}-pprint \
30"