blob: bde9935ffe62e47fdc4363edbdcdd67ab5cb9743 [file] [log] [blame]
Andrew Geissler69721092021-07-23 12:57:00 -04001# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "A ``pytest`` fixture for benchmarking code. It will group the tests into rounds that are calibrated to the chosen timer."
5HOMEPAGE = "https://github.com/ionelmc/pytest-benchmark"
6LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=9c5c2c74370826468065c5702b8a1fcf"
8
9SRC_URI[sha256sum] = "40e263f912de5a81d891619032983557d62a3d85843f9a9f30b98baea0cd7b47"
10
11inherit pypi setuptools3
12
Patrick Williams213cb262021-08-07 19:21:33 -050013RDEPENDS:${PN} += "python3-core python3-py-cpuinfo python3-pytest python3-aspectlib"
Andrew Geissler69721092021-07-23 12:57:00 -040014
15BBCLASSEXTEND = "native nativesdk"