blob: 68b3db1f48cf3c2385c6bdf57861f4741acc7e7d [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Pure python rfc3986 validator"
2HOMEPAGE = "https://github.com/naimetti/rfc3986-validator"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a21b13b5a996f08f7e0b088aa38ce9c6"
5
Patrick Williams213cb262021-08-07 19:21:33 -05006FILESEXTRAPATHS:prepend := "${THISDIR}/python-rfc3986-validator:"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007
8SRC_URI[md5sum] = "47f7657b790aaf6011a1ab3d86c6be95"
9SRC_URI[sha256sum] = "3d44bde7921b3b9ec3ae4e3adca370438eccebc676456449b145d533b240d055"
10
11PYPI_PACKAGE = "rfc3986_validator"
12
13inherit pypi setuptools3
14
Patrick Williams213cb262021-08-07 19:21:33 -050015SRC_URI:append = " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050016 file://0001-setup.py-move-pytest-runner-to-test_requirements.patch \
17"
18
Patrick Williams213cb262021-08-07 19:21:33 -050019RDEPENDS:${PN} += "\
Andrew Geissler82c905d2020-04-13 13:39:40 -050020 python3-core \
21"
22
23BBCLASSEXTEND = "native nativesdk"