blob: 7c6c41af7cacb0bd7f99822a8514fc68d087c97f [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A Python generic test automation framework"
2DESCRIPTION = "Generic open source test atomation framework for acceptance\
3testing and acceptance test-driven development (ATDD). It has easy-to-use\
4tabular test data syntax and it utilizes the keyword-driven testing approach.\
5Its testing capabilities can be extended by test libraries implemented either\
6with Python or Java, and users can create new higher-level keywords from\
7existing ones using the same syntax that is used for creating test cases."
8HOMEPAGE = "http://robotframework.org"
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
12inherit pypi setuptools3
13
Andrew Geisslerd221e032020-07-10 16:13:21 -050014PYPI_PACKAGE_EXT = "zip"
Andrew Geissler32b11992021-03-31 13:37:05 -050015
Patrick Williams213cb262021-08-07 19:21:33 -050016SRC_URI[sha256sum] = "567f2a21f0906635e21d45fe3cb84a4809a12980c9f2706a8a5f65f40f6b4ccd"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
Patrick Williams213cb262021-08-07 19:21:33 -050018RDEPENDS:${PN} += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050019 ${PYTHON_PN}-shell \
20 ${PYTHON_PN}-pprint \
21 ${PYTHON_PN}-xml \
22 ${PYTHON_PN}-difflib \
23 ${PYTHON_PN}-threading \
24 ${PYTHON_PN}-html \
25 ${PYTHON_PN}-docutils \
26 ${PYTHON_PN}-ctypes \
Patrick Williams213cb262021-08-07 19:21:33 -050027 ${PYTHON_PN}-logging \
28 ${PYTHON_PN}-numbers \
Andrew Geissler82c905d2020-04-13 13:39:40 -050029"