blob: 00d83ab61b81cc678efd1376fee13246b764eb8c [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Convenience functions for dbus services in Python 2.x"
2HOMEPAGE = "https://github.com/nphilipp/python-slip"
3DESCRIPTION = "\
4The Simple Library for Python 2.x packages contain miscellaneous code for \
5convenience, extension and workaround purposes. \
6\
7This package provides slip.dbus.service.Object, which is a dbus.service.Object \
8derivative that ends itself after a certain time without being used and/or if \
9there are no clients anymore on the message bus, as well as convenience \
10functions and decorators for integrating a dbus service with PolicyKit."
11
12SECTION = "devel/python"
13LICENSE = "GPLv2+"
14LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
15SRCNAME = "python-slip"
16
17SRC_URI = "https://github.com/nphilipp/${SRCNAME}/releases/download/${SRCNAME}-${PV}/${SRCNAME}-${PV}.tar.bz2"
18S = "${WORKDIR}/${SRCNAME}-${PV}"
19
20SRC_URI[md5sum] = "28ae5f93853466c44ec96706ba2a1eb4"
21SRC_URI[sha256sum] = "c726c086f0dd93a0ac7a0176f383a12af91b6657b78a301e3f5b25d9f8d4d10b"
22
Patrick Williams213cb262021-08-07 19:21:33 -050023do_compile:prepend() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050024 sed -e 's/@VERSION@/${PV}/g' ${S}/setup.py.in > ${S}/setup.py
25}
26
Patrick Williams213cb262021-08-07 19:21:33 -050027RDEPENDS:${PN} += "\
Andrew Geissler82c905d2020-04-13 13:39:40 -050028 ${PYTHON_PN}-six \
29"
30# http://errors.yoctoproject.org/Errors/Details/184713/
31# python-native/python: can't open file 'setup.py': [Errno 2] No such file or directory
32CLEANBROKEN = "1"
33
Brad Bishop19323692019-04-05 15:28:33 -040034inherit setuptools3