blob: 0d63803bb6d44aab7de99be667fbee164fa2fc6d [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001# This recipe is originally from meta-openstack:
2# https://git.yoctoproject.org/cgit/cgit.cgi/meta-cloud-services/tree/meta-openstack/recipes-devtools/python/python3-uritemplate_3.0.0.bb?h=master
3
4SUMMARY = "Simple python library to deal with URI Templates."
5AUTHOR = "Ian Cordasco"
6LICENSE = "Apache-2.0 | BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=0f6d769bdcfacac3c1a1ffa568937fe0"
8
9SRC_URI[md5sum] = "869fb44fbd56713490db7272eb36c8ae"
10SRC_URI[sha256sum] = "5af8ad10cec94f215e3f48112de2022e1d5a37ed427fbd88652fa908f2ab7cae"
11
Andrew Geisslerd221e032020-07-10 16:13:21 -050012inherit pypi setuptools3 ptest
13
14SRC_URI += " \
15 file://run-ptest \
16"
17
Patrick Williams213cb262021-08-07 19:21:33 -050018RDEPENDS:${PN}-ptest += " \
Andrew Geisslerd221e032020-07-10 16:13:21 -050019 ${PYTHON_PN}-pytest \
20"
21
22do_install_ptest() {
23 install -d ${D}${PTEST_PATH}/tests
24 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
25}
Andrew Geissler82c905d2020-04-13 13:39:40 -050026
27BBCLASSEXTEND = "native nativesdk"