blob: a6ca4d5f83f70030f428db848aa62046fab2906e [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Python WBEM Client and Provider Interface"
2DESCRIPTION = "\
3A Python library for making CIM (Common Information Model) operations over \
4HTTP using the WBEM CIM-XML protocol. It is based on the idea that a good \
5WBEM client should be easy to use and not necessarily require a large amount \
6of programming knowledge. It is suitable for a large range of tasks from \
7simply poking around to writing web and GUI applications. \
8\
9WBEM, or Web Based Enterprise Management is a manageability protocol, like \
10SNMP, standardised by the Distributed Management Task Force (DMTF) available \
11at http://www.dmtf.org/standards/wbem. \
12\
13It also provides a Python provider interface, and is the fastest and easiest \
14way to write providers on the planet."
15HOMEPAGE = "http://pywbem.github.io"
16LICENSE = "LGPLv2.1"
Brad Bishope42b3e32020-01-15 22:08:42 -050017LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fbc093901857fcd118f065f900982c24"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070019SRC_URI[sha256sum] = "8ef48185e0adbaeb9bd5181c4c5de951f6d58d54e2e1d7e87a9834e10eabe957"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020
Andrew Geisslerd221e032020-07-10 16:13:21 -050021inherit pypi setuptools3 update-alternatives
Brad Bishope42b3e32020-01-15 22:08:42 -050022
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023DEPENDS += " \
24 ${PYTHON_PN}-ply-native \
25 ${PYTHON_PN}-pyyaml-native \
26 ${PYTHON_PN}-six-native \
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070027 ${PYTHON_PN}-wheel-native \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028"
29
Patrick Williams213cb262021-08-07 19:21:33 -050030RDEPENDS:${PN}:class-target += "\
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031 ${PYTHON_PN}-datetime \
32 ${PYTHON_PN}-io \
33 ${PYTHON_PN}-netclient \
34 ${PYTHON_PN}-ply \
35 ${PYTHON_PN}-pyyaml \
36 ${PYTHON_PN}-six \
37 ${PYTHON_PN}-stringold \
38 ${PYTHON_PN}-threading \
39 ${PYTHON_PN}-unixadmin \
40 ${PYTHON_PN}-xml \
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070041 ${PYTHON_PN}-nocasedict \
42 ${PYTHON_PN}-nocaselist \
43 ${PYTHON_PN}-yamlloader \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080044"
45
Patrick Williams213cb262021-08-07 19:21:33 -050046ALTERNATIVE:${PN} = "mof_compiler"
Andrew Geisslerd221e032020-07-10 16:13:21 -050047ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler"
Andrew Geisslerd221e032020-07-10 16:13:21 -050048
49ALTERNATIVE_PRIORITY = "60"
50
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080051BBCLASSEXTEND = "native"