blob: 8a30b74c8103faedc7bb9fec0f6a65233484aaf8 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "A simple, small, portable, fast, and secure HTTP server"
2DESCRIPTION = "A simple, small, portable, fast, and secure HTTP server (supported fork of thttpd)."
3HOMEPAGE = "http://opensource.dyc.edu/sthttpd"
4LICENSE = "BSD-2-Clause"
5LIC_FILES_CHKSUM = "file://src/thttpd.c;beginline=1;endline=26;md5=0c5762c2c34dcbe9eb18815516502872"
6
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007DEPENDS += "base-passwd virtual/crypt"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05008
Brad Bishop26bdd442019-08-16 17:08:17 -04009SRCREV = "2845bf5bff2b820d2336c8c8061cbfc5f271e720"
10SRC_URI = "git://github.com/blueness/${BPN} \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050011 file://thttpd.service \
12 file://thttpd.conf \
13 file://init"
14
Brad Bishop316dfdd2018-06-25 12:45:53 -040015UPSTREAM_CHECK_URI = "https://github.com/blueness/sthttpd/releases/"
16UPSTREAM_CHECK_REGEX = "v(?P<pver>\d+(\.\d+)+).tar.gz"
17
Brad Bishop26bdd442019-08-16 17:08:17 -040018S = "${WORKDIR}/git"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020inherit autotools update-rc.d systemd update-alternatives
21
22ALTERNATIVE_PRIORITY = "100"
Patrick Williams213cb262021-08-07 19:21:33 -050023ALTERNATIVE:${PN}-doc = "htpasswd.1"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024ALTERNATIVE_LINK_NAME[htpasswd.1] = "${mandir}/man1/htpasswd.1"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050025
26SRV_DIR ?= "${servicedir}/www"
27
28# Note that `${sbindir}/makeweb' is installed setgid to this group,
29# but ${SRV_DIR} is not installed chgrp'd to the group by default.
30WEBGROUP ?= "www-data"
31
Patrick Williams213cb262021-08-07 19:21:33 -050032do_configure:prepend () {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050033 export WEBDIR=${SRV_DIR}
34 export WEBGROUP=${WEBGROUP}
35}
36
Patrick Williams213cb262021-08-07 19:21:33 -050037do_install:append () {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050038 install -d ${D}${sysconfdir}/init.d
39 install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/thttpd
40 install -c -m 755 ${WORKDIR}/thttpd.conf ${D}${sysconfdir}
41 sed -i -e 's,@@CONFFILE,${sysconfdir}/thttpd.conf,g' ${D}${sysconfdir}/init.d/thttpd
42 sed -i -e 's,@@SRVDIR,${SRV_DIR},g' ${D}${sysconfdir}/thttpd.conf
43 sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/thttpd
44
45 install -d ${D}${systemd_unitdir}/system
46 install -m 0644 ${WORKDIR}/thttpd.service ${D}${systemd_unitdir}/system
47 sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${systemd_unitdir}/system/thttpd.service
48 sed -i 's!/var/!${localstatedir}/!g' ${D}${systemd_unitdir}/system/thttpd.service
49 sed -i -e 's,@@CONFFILE,${sysconfdir}/thttpd.conf,g' ${D}${systemd_unitdir}/system/thttpd.service
50}
51
52INITSCRIPT_NAME = "thttpd"
53INITSCRIPT_PARAMS = "defaults"
54
Patrick Williams213cb262021-08-07 19:21:33 -050055SYSTEMD_SERVICE:${PN} = "thttpd.service"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050056
Patrick Williams213cb262021-08-07 19:21:33 -050057FILES:${PN} += "${SRV_DIR}"
58FILES:${PN}-dbg += "${SRV_DIR}/cgi-bin/.debug"