blob: b03517bf1ac83792a0d809e602e1b61e18f29d3a [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Debugging and profiling extension for PHP"
2LICENSE = "Xdebug"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=92d94a330d34ee6edc2638450736f119"
4
5DEPENDS = "php re2c-native"
6
7SRC_URI = "http://xdebug.org/files/xdebug-${PV}.tgz"
8
9SRC_URI[md5sum] = "c04be1bf225b768bf627dc92e5a1f9df"
10SRC_URI[sha256sum] = "775b1705109611b996d6a713fe14117a67846e157eb7dbf349bc0b055e861a10"
11
12UPSTREAM_CHECK_REGEX = "xdebug-(?P<pver>\d+(\.\d+)+)\.tgz"
13
14inherit autotools
15
16EXTRA_OECONF += "--enable-xdebug -with-php-config=${STAGING_BINDIR_CROSS}/php-config"
17
18do_configure() {
19 cd ${S}
20 ${STAGING_BINDIR_CROSS}/phpize
21 cd ${B}
22
23 # Running autoreconf as autotools_do_configure would do here
24 # breaks the libtool configuration resulting in a failure later
25 # in do_compile. It's possible this may be fixable, however the
26 # easiest course of action for the moment is to avoid doing that.
27 oe_runconf
28}
29
30do_install() {
31 oe_runmake install INSTALL_ROOT=${D}
32}
33
Patrick Williams213cb262021-08-07 19:21:33 -050034FILES:${PN} += "${libdir}/php*/extensions/*/*.so"
35FILES:${PN}-dbg += "${libdir}/php*/extensions/*/.debug"