blob: c81fb03f77424f2e53b1c92b030dbe4f9ed63f80 [file] [log] [blame]
Andrew Geissler15ad1112021-01-08 16:09:43 -06001SUMMARY = "Some examples using the DispmanX API on the Raspberry Pi"
2HOMEPAGE = "https://github.com/AndrewFromMelbourne/raspidmx"
3SECTION = "graphics"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=52962875ab02c36df6cde47b1f463024"
6
7COMPATIBLE_HOST = "null"
Patrick Williams213cb262021-08-07 19:21:33 -05008COMPATIBLE_HOST:rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', 'null', '(.*)', d)}"
Andrew Geissler15ad1112021-01-08 16:09:43 -06009
10SRC_URI = "git://github.com/AndrewFromMelbourne/raspidmx;protocol=https \
11 file://0001-gitignore-add-archives-from-lib-directory.patch \
12 file://0002-add-install-targets-to-Makefiles.patch \
13 file://0003-switch-to-pkg-config.patch \
14 file://0004-add-libvchostif-to-link.patch \
15 file://0005-change-library-linking-order.patch \
16 file://0006-game-Makefile-install-sample-png-files.patch \
17 file://0007-Makefile-reorganize.patch \
18 "
19
20PV = "0.0+git${SRCPV}"
21SRCREV = "e2ee6faa0d01a5ece06bcc74a47f37d7e6837310"
22
23S = "${WORKDIR}/git"
24
25inherit pkgconfig
26
27DEPENDS += "libpng userland"
28
29do_install () {
30 oe_runmake 'DESTDIR=${D}' 'TARGET=install'
31}