blob: 74f5d3923afb6cad01077980d039d02aef82e346 [file] [log] [blame]
Andrew Geissler1fe918a2020-05-15 14:16:47 -05001SUMMARY = "Checksec tool"
2DESCRIPTION = "The checksec.sh script is designed to test what standard Linux OS and PaX security features are being used."
3SECTION = "security"
4LICENSE = "BSD-3-Clause"
5HOMEPAGE="http://www.trapkit.de/tools/checksec.html"
6
7LIC_FILES_CHKSUM = "file://checksec-${PV}.sh;beginline=3;endline=34;md5=6dab14470bfdf12634b866dbdd7a04b0"
8
9SRC_URI = "http://www.trapkit.de/tools/checksec.sh;downloadfilename=checksec-${PV}.sh"
10
11SRC_URI[md5sum] = "57cc3fbbbe48e8ebd4672c569954374d"
12SRC_URI[sha256sum] = "05822cd8668589038d20650faa0e56f740911d8ad06f7005b3d12a5c76591b90"
13
14
15S = "${WORKDIR}"
16
17do_install() {
18 install -d ${D}${bindir}
19 install -m 0755 ${WORKDIR}/checksec-${PV}.sh ${D}${bindir}/checksec.sh
20 sed -i 's/\r//' ${D}${bindir}/checksec.sh
21}
22
Patrick Williams213cb262021-08-07 19:21:33 -050023RDEPENDS:${PN} = "bash binutils"
Andrew Geissler1fe918a2020-05-15 14:16:47 -050024
25BBCLASSEXTEND = "native"