blob: 000e3bb73352d055b1f530f0decb0ec4b674524c [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Linux system security checks"
2DESCRIPTION = "The checksec script is designed to test what standard Linux OS and PaX security features are being used."
3SECTION = "security"
4LICENSE = "BSD"
5HOMEPAGE="https://github.com/slimm609/checksec.sh"
6
Andrew Geissler8b139282021-03-05 15:22:30 -06007LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8d90285f711cf1f378e2c024457066d8"
Brad Bishop19323692019-04-05 15:28:33 -04008
Andrew Geissler8b139282021-03-05 15:22:30 -06009SRCREV = "c3754e45e04f9104db93b2048afd094427102d48"
Brad Bishop19323692019-04-05 15:28:33 -040010SRC_URI = "git://github.com/slimm609/checksec.sh"
11
12S = "${WORKDIR}/git"
13
14do_install() {
15 install -d ${D}${bindir}
16 install -m 0755 ${S}/checksec ${D}${bindir}
17}
18
Patrick Williams213cb262021-08-07 19:21:33 -050019RDEPENDS:${PN} = "bash openssl-bin binutils"