blob: 4a84a9fad85252348aec09f3bdf9909882cf3671 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Example of how to build an external Linux kernel module"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05002DESCRIPTION = "${SUMMARY}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05003LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
5
6inherit module
7
8SRC_URI = "file://Makefile \
9 file://hello.c \
10 file://COPYING \
11 "
12
13S = "${WORKDIR}"
14
15# The inherit of module.bbclass will automatically name module packages with
16# "kernel-module-" prefix as required by the oe-core build environment.
Brad Bishop316dfdd2018-06-25 12:45:53 -040017
Patrick Williams213cb262021-08-07 19:21:33 -050018RPROVIDES:${PN} += "kernel-module-hello"