blob: 674d2434e0b3cb13ee91c458410bf2a7b2ac1d8e [file] [log] [blame]
Andrew Geissler1e34c2d2020-05-29 16:02:59 -05001# Handle Go Modules support
2#
3# When using Go Modules, the the current working directory MUST be at or below
4# the location of the 'go.mod' file when the go tool is used, and there is no
5# way to tell it to look elsewhere. It will automatically look upwards for the
6# file, but not downwards.
7#
8# To support this use case, we provide the `GO_WORKDIR` variable, which defaults
9# to `GO_IMPORT` but allows for easy override.
10#
11# Copyright 2020 (C) O.S. Systems Software LTDA.
12
13# The '-modcacherw' option ensures we have write access to the cached objects so
14# we avoid errors during clean task as well as when removing the TMPDIR.
Patrick Williams213cb262021-08-07 19:21:33 -050015GOBUILDFLAGS:append = " -modcacherw"
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050016
17inherit go
18
19GO_WORKDIR ?= "${GO_IMPORT}"
20do_compile[dirs] += "${B}/src/${GO_WORKDIR}"