blob: 5dd72c9dad82d32e68230fbd984b4f9b7162a290 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001inherit ptest
2
Patrick Williams213cb262021-08-07 19:21:33 -05003FILESEXTRAPATHS:prepend := "${COREBASE}/meta/files:"
Brad Bishop316dfdd2018-06-25 12:45:53 -04004
5SRC_URI += "file://ptest-perl/run-ptest"
6
7do_install_ptest_perl() {
8 install -d ${D}${PTEST_PATH}
9 if [ ! -f ${D}${PTEST_PATH}/run-ptest ]; then
10 install -m 0755 ${WORKDIR}/ptest-perl/run-ptest ${D}${PTEST_PATH}
11 fi
12 cp -r ${B}/t ${D}${PTEST_PATH}
13 chown -R root:root ${D}${PTEST_PATH}
14}
15
Patrick Williams213cb262021-08-07 19:21:33 -050016FILES:${PN}-ptest:prepend = "${PTEST_PATH}/t/* ${PTEST_PATH}/run-ptest "
Brad Bishop316dfdd2018-06-25 12:45:53 -040017
Patrick Williams213cb262021-08-07 19:21:33 -050018RDEPENDS:${PN}-ptest:prepend = "perl "
Brad Bishop316dfdd2018-06-25 12:45:53 -040019
20addtask install_ptest_perl after do_install_ptest_base before do_package
21
22python () {
23 if not bb.data.inherits_class('native', d) and not bb.data.inherits_class('cross', d):
24 d.setVarFlag('do_install_ptest_perl', 'fakeroot', '1')
25
26 # Remove all '*ptest_perl' tasks when ptest is not enabled
27 if not(d.getVar('PTEST_ENABLED') == "1"):
28 for i in ['do_install_ptest_perl']:
29 bb.build.deltask(i, d)
30}